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Introduction
This document is meant to provide students with a basic understanding of SPSS, the statistical software 
package that is used for homework assignments in this course.  Some of this material is presented in 
class lecture, and each homework assignment includes the minimal instructions needed to complete the 
assignment, but this document provides more detail.  

The screenshots in this document are from SPSS Statistics version 24 and PSPP version 1.2.0 on the 
Mac, but other versions and platforms should be very similar in all but cosmetic ways.

This is still  a work in progress,  but it  will  be updated periodically.   This document will  eventually 
provide guidelines and instructions for other uses of SPSS that were not used in this course, but that 
might be helpful for anybody wishing to go further with SPSS in their own research or employment.  

Please  contact  Dr.  Hensel  (phensel@unt.edu)  with  any  questions  or  suggestions  regarding  this 
document. My goal is to make this as useful as possible, so I appreciate any reactions you might have.

Version History
• 1.12: November 17, 2019 (Added more details related to crosstabs, scatterplots, and correlations as 
needed for the next homework assignment, including notes about the differences between SPSS and 
PSPP in running these types of analyses)
•  1.11:  November  1,  2019   (Added  links  to  the  official  SPSS  and  PSPP documentation  for  each 
command's syntax and to additional tutorials or references for most commands, improved the discussion 
of how to open various types of data sets, and added better descriptions of how PSPP is similar/different 
for commands used in class homework assignments)
• 1.10: October 11, 2019  (Added more details and screenshots related to the use of PSPP rather than 
SPSS,  added  explanation  of  how  to  copy  SPSS/PSPP output  so  you  can  paste  it  into  your  word 
processing document, and added more links to online resources on topics that are not yet covered in this 
guide)
• 1.05: April 2018  (Added more details about the analyses that have been assigned for class homework 
assignments,  and mentioned the SPSS techniques used for  the more advanced techniques that  were 
discussed in class but not used in any homework assignments)
• 1.0-1.04: March 2018  (The first preliminary version of this document was released during the Spring 
2018 semester and was updated several times as new assignments were due)
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Accessing SPSS or PSPP
SPSS
There are several different ways for you to use SPSS statistical software to complete several of the 
homework assignments for this course:
• SPSS is installed in many (most? all?) UNT computer labs, so you may use it there for free.
• If you are interested in getting your own copy of SPSS rather than depending on computer labs, you 
may rent a license for it  through UNT at a substantial  student discount.   You will  need the "SPSS 
Statistics" version of the SPSS Grad Pack, which is available for both Mac and Windows at a cost of 
approximately $60 (6 month license) or $90 (12 month license) at the following site for UNT students:

<https://untsystem.onthehub.com/WebStore/ProductsByMajorVersionList.aspx>
• After you have graduated and no longer qualify for the campus discount, you will probably have to pay 
full price for SPSS, unless you enroll at another college/university for graduate/professional school or 
you are hired by an employer that provides it for employees.  This can be very pricey; they currently  
charge $99/month for the "Base" package and even more for add-on packages with additional features 
(for  example,  such  techniques  as  logistic  regression,  multinomial  logistic  regression,  event  count 
analysis,  and  survival  analysis  are  only  available  in  the  optional  "Custom  Tables  and  Advanced 
Statistics" package that costs another $79/month):

<https://www.ibm.com/products/spss-statistics>

PSPP
There is also a free open-source statistical package called PSPP that is claimed to be very similar to 
SPSS: "it behaves as experienced SPSS users would expect, and their system files and syntax files can 
be used in PSPP with little or no modification, and will produce similar results (the actual numbers 
should be identical)". In my testing, this works perfectly well for this course's homework assignments; it 
reads SPSS data files, offers the same commands (usually in the same place in the dropdown menus and 
with the same command syntax), and produces identical results.  This may be downloaded freely for 
Mac, Windows, and Linux platforms:

<https://www.gnu.org/software/pspp/>

Students are welcome to use PSPP if they would like to avoid paying for their own SPSS license or 
having to go to a campus computing lab, and it will remain available for free usage after you graduate 
and no longer qualify for the SPSS student discount or have access to UNT computer labs.  There are a 
few limitations of PSPP, although these will not limit its usability for this course.  Some of the more 
advanced statistical techniques discussed at the end of the class are not currently implemented in PSPP, 
so it may not be able to do everything you will need to do in your own research.  PSPP also feels much 
clunkier,  which isn't  surprising --  SPSS has been around since the 1960s and is  owned by a major 
corporation (IBM), so there has been a lot of time for its many well-paid programmers to improve the 
interface. PSPP is free software that is usually programmed by volunteers and is meant to run on many 
platforms (Mac, Windows, Linux), trying to look and work the same on all of them.  PSPP's dropdown 
menus are only available at the top of the Data Editor window (they are not included in the Output 
Viewer or Syntax Editor screens, and unlike most native Mac or Windows software, the menus are not 
included  in  the  menu  bar  at  the  top  of  the  computer  screen).   Also,  unlike  SPSS,  PSPP will  not 
automatically start up and open a data file if you double-click on the file or try to drag the file to the 
PSPP application's icon; you need to start up the application separately, and then use the dropdown menu 
or the syntax editor to open the data file manually.

https://untsystem.onthehub.com/WebStore/ProductsByMajorVersionList.aspx
https://www.ibm.com/products/spss-statistics
https://www.gnu.org/software/pspp/
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Using SPSS or PSPP

Opening the Software
The easiest way to start SPSS is to double-click on a .sav SPSS data file, which should automatically 
open SPSS and bring up the Data Editor window with the data set already open.  This does not work 
with PSPP, though, even if you use the computer's preferences to set PSPP as the application that should 
automatically open such files.

You may open either SPSS or PSPP manually by double-clicking on the SPSS or PSPP app's  icon 
directly or by clicking on an alias/shortcut from the main screen, the MacOS dock, or the Windows Start 
menu. 

Switching Between Windows
SPSS uses a number of different windows or screens for different purposes.  Whenever SPSS is open, 
you may use the "Window" item in the menu bar at the top of the screen to move between the three main 
windows that are used.

Using PSPP
PSPP uses similar windows, but the graphical user interface menus do not appear at  the top of the 
screen.  These menus only appear at the top of the Data Editor window, not the Syntax Editor or Output 
Viewer windows.

The "Data Editor" Window
Assuming that you opened SPSS by double-clicking on an SPSS ,sav data file, once SPSS has finished 
opening, you will probably see a spreadsheet with a list of variable names across the top.  SPSS calls 
this spreadsheet the Data Editor window, and these numbers are the data set that you will be using.  You 
may view or edit the data from this screen if desired, although that usually won't be necessary.
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Using PSPP
This window looks similar in PSPP.  As noted above, this window is the only place in PSPP where you 
can access the dropdown menus to carry out commands.

The "Output Viewer" Window (and copying output for your homework assignments)
Once you have run at least one operation or analysis (whether using a dropdown menu or a syntax file), 
this window will display the results, and allow you to copy the tables or graphs so you can paste them 
into a word processing document.  In SPSS, you can usually use your mouse to click on the specific 
table, graph, or result and copy it (by right-clicking or using the dropdown "Copy" command), then 
paste this into your word processing document.

Using PSPP
This window looks similar in PSPP.  It is a little trickier copying output from PSPP to use in your 
homework  assignments,  because  PSPPs  Output  Viewer  doesn't  allow  right-clicking  directly  on  the 
output to copy it and paste it elsewhere.  The solution is to select the specific portion of the output in the 
list on the left side of the Output Viewer (you may need to click the triangle in the list to show specific 
portions of the output), then go up to the Edit menu above the top of the list, and click "Copy"; this 
copied output can then be pasted into your word processing document.
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The "Syntax Editor" Window
This window is used to enter or edit commands manually, without using the graphical user interface.  
You won't need to use this window for this course, but it will probably be very useful to you if you ever 
need to use SPSS later for your research or for a job.  More details on using the syntax editor are 
provided in an appendix to this document.

Using PSPP
This window looks similar in PSPP.

Opening SPSS (.sav) Data Sets
All data files needed for homework assignments in my course are provided for you in SPSS .sav format 
(posted  alongside  the  homework  assignments  that  require  them).   Any  SPSS  data  file  should 
automatically  work  with  your  copy  of  SPSS  or  PSPP,  but  if  you  go  beyond  the  class  homework 
assignments, you may want to try to open other types of files.  SPSS and, to a certain extent, PSPP can 
open data sets in some alternative formats, as well as importing raw data or spreadsheet files.

With SPSS, you can open an SPSS .sav data file by double-clicking directly on the file itself on your 
computer, whether or not SPSS is already running.  This does not work with PSPP, though.

Once SPSS or PSPP is running, you can use the File menu to select and open the .sav data file that you 
want to work with: File > Open > Data, or else you will need to open the data from a syntax file (as 
described in the Syntax Files appendix to this document):
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Opening or Importing Other Types of Data
Comma-Delimited or Tab-Delimited Files (.csv, .txt ,or .dat)
Many  professional  data  sets  are  downloadable  in  this  format,  because  it  is  easy  to  open  in  any 
spreadsheet or statistics package.
• Official SPSS Syntax Documentation: GET, GET DATA
• Official PSPP Documentation: GET, GET DATA, GET DATA-text files
• Kent State Statistical Consulting: Importing Data into SPSS
• UCLA Statistical Consulting Group: How to Read Raw Data into SPSS

Spreadsheet Files (.xls, .xlsx, or .xlsm / ,gnm or .ods)
Many data sets are originally created and maintained in Excel or another spreadsheet format. SPSS can 
open Excel (.xls, .xlsx, or .xlsm) spreadsheet files directly without first converting them to .csv or a 
similar  format.   PSPP is  more  limited,  only  opening  spreadsheet  files  from  Gnumeric  (.gnm)  or 
OpenDocument (.ods) formats.  To use formats that can not be opened directly, you will need to convert 
them to comma- or tab-delimited text files and follow the instructions above.
• Official SPSS Syntax Documentation: GET, GET DATA
• Official PSPP Documentation: GET, GET DATA, GET DATA-spreadsheet files
• Kent State Statistical Consulting: Importing Data into SPSS
• UCLA Statistical Consulting Group: How to Read Raw Data into SPSS

Other Data Formats
SPSS can also read data saved in other formats, although PSPP does not currently offer this.  There are 
separate commands to read in data files from the SAS and STATA statistical software, as well as a 
command to read in files from many types of databases (dBase, Lotus 1-2-3, Symphony, Systat).
• Official SPSS Syntax Documentation: GET SAS, GET STATA, GET TRANSLATE

Entering Data in SPSS
Most  scholars  prefer  to  enter  their  data  in  spreadsheets  like  Microsoft  Excel,  or  in  databases  like 
Filemaker or  Microsoft  Access,  and then read the raw data into SPSS using one of  the commands 
described above.  If you prefer to enter your data directly in SPSS, here are some resources to help.
• Kent State Statistical Consulting: Data Creation in SPSS
• NC State's SPSS Tutorials: Creating a Dataset
• UCLA Statistical Consulting Group: How to Input Data into the SPSS Data Editor
• UNT's SPSS Short Course: Familiarization with SPSS - Creating a Data File

https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_get.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_get_data.htm
https://www.gnu.org/software/pspp/manual/html_node/GET.html
https://www.gnu.org/software/pspp/manual/html_node/GET-DATA.html
https://www.gnu.org/software/pspp/manual/html_node/GET-DATA-_002fTYPE_003dTXT.html
https://libguides.library.kent.edu/SPSS/ImportData
https://stats.idre.ucla.edu/spss/modules/how-to-read-raw-data-into-spss/
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_get.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_get_data.htm
https://www.gnu.org/software/pspp/manual/html_node/GET.html
https://www.gnu.org/software/pspp/manual/html_node/GET-DATA.html
https://www.gnu.org/software/pspp/manual/html_node/GET-DATA-_002fTYPE_003dGNM_002fODS.html
https://libguides.library.kent.edu/SPSS/ImportData
https://stats.idre.ucla.edu/spss/modules/how-to-read-raw-data-into-spss/
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_get_sas.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_get_stata.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_get_translate.htm
https://libguides.library.kent.edu/SPSS/CreateData
https://it.chass.ncsu.edu/tutorials/spss/section2.php
https://stats.idre.ucla.edu/spss/modules/how-to-input-data-into-the-spss-data-editor/
http://bayes.acs.unt.edu:8083/BayesContent/class/Jon/SPSS_SC/Module1/SPSS_M1.htm
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Summarizing the Data Set

Variable Codebook: "DISPLAY"
You can also get a list of basic variable information with the following command: File > Display Data 
File Information > Working File.

This will provide two tables with information about each variable in the data set.  Most important, the 
first table lists the name of each variable and the full variable label:

The second table only applies to variables that have specific value labels, or text attached to one or more 
of the possible values that the variable can take on (typically used for nominal or ordinal variables, but 
this can sometimes be used for a few meaningful values of interval/ratio variables):
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Syntax
To do this in a syntax file:

DISPLAY DICTIONARY.

To limit the display to selected variables only:
DISPLAY DICTIONARY
    /VARIABLES = VAR1 VAR2 VAR3.

To sort the variables alphabetically, rather than in the order in which they appear in the data file:
DISPLAY SORTED  DICTIONARY

Using PSPP
The same basic menu command (File > Display Data File Information > Working File) and syntax 
command (DISPLAY DICTIONARY) also work in PSPP.  In fact, the output in PSPP seems to be better 
organized -- whereas SPSS displays separate tables for variable labels and value labels, PSPP displays 
value labels inside the main variable labels table, so all of the information about each variable is easily 
available in a single place.

Other Resources
• Official SPSS Syntax Documentation: DISPLAY
• Official PSPP Documentation: DISPLAY

Alternative Option: "CODEBOOK"
One of the first things you should do when you start using a new data set is put together a list of all 
variables (with their full name/label), and for nominal or ordinal variables, a list of all values (with the 
label for each).  Without doing this, you won't know what your data look like, you won't know what the 
possible values are for each variable, and you may not be able to identify values that are impossible or 
that represent missing data when you run descriptive analyses.

The easiest way to do this in SPSS is using the Codebook command, which you can access from the 
Analyze menu:  Analyze > Reports > Codebook.  Unfortunately, this option is not available for PSPP.

https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_display.htm
https://www.gnu.org/software/pspp/manual/html_node/DISPLAY.html
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Once you have selected the Codebook command, highlight the variables that you want to include, click 
the button in the middle of the window to transfer these to the list of Codebook Variables, then click OK:

This will produce something like the following for each variable -- note especially the Label cell (which 
shows the full variable label), the Valid Values (the numeric value for all values of this if it is a nominal 
or ordinal variable), and the value label for each valid value.
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Syntax
To do this in a syntax file:

CODEBOOK.

You may choose to limit this command to certain variables:
CODEBOOK VAR1 VAR2 VAR3.

You may choose to limit this command to a subset of the possible information about each variable; the 
following list will limit this to the most useful information:

CODEBOOK
    /VARINFO LABEL TYPE FORMAT VALUELABELS MISSING.

You  may  choose  to  add  several  basic  descriptive  statistics  to  this  output,  although  most  of  the 
descriptives you might need are not available here:

CODEBOOK
    /STATISTICS COUNT PERCENT MEAN STDDEV QUARTILES.

Using PSPP
PSPP does not implement the Codebook command in version 1.2.0.  It may be added in a future version, 
though.

Other Resources
• Official SPSS Syntax Documentation: CODEBOOK

https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_codebook.htm
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Descriptive Statistics

Frequency Distributions: "FREQUENCIES"
The easiest  way to  display  the  frequency distribution  for  any  variable  in  the  data  set  is  using  the 
Frequencies  command,  which  you  can  access  from  the  Analyze  menu:   Analyze  >  Descriptive 
Statistics > Frequencies:

This command will open a dialog box that allows you to choose one or more variables, in order to 
display their frequencies. Select the variable(s) you want to examine on the left side of this box, push the 
arrow button in the middle of the screen, and the variable(s) should then appear in the list at the right 
side of the box; once this happens, click OK.

This will give you a frequency table with a variety of frequency-related details for each value of the 
variable: the frequency count (the number of cases that have this value), the percentage of cases, the 
valid percentage of cases, and the cumulative percentage of cases.  (You can modify this list to add or 
remove statistics by clicking the "Statistics" button, as will be described below)
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Syntax
• Instructions for doing this in a syntax file will be provided later.

Using PSPP
• The same basic menu command (Analyze > Descriptive Statistics > Frequencies) also works in 
PSPP. 

Other Resources
• Official SPSS Syntax Documentation: FREQUENCIES
• Official PSPP Documentation: FREQUENCIES
• Furman University SPSS Tutorials: Descriptive Statistics and Graphs
•  Kent  State  University  Libraries  Statistical  Consulting:  Frequency Tables,  Descriptive Stats for One 
Numeric Variable (FREQUENCIES), 
• UCLA Statistical Consulting Group: Annotated Output

Bar Graphs, Pie Charts, and Histograms: "FREQUENCIES"
The easiest way to display graphs, charts, or histograms for any variable in the data set is (surprisingly) 
using  the  Frequencies  command,  which  you  can  access  from  the  Analyze  menu:   Analyze  > 
Descriptive Statistics > Frequencies:

https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_frequencies.htm
https://www.gnu.org/software/pspp/manual/html_node/FREQUENCIES.html#FREQUENCIES
http://eweb.furman.edu/~lpace/SPSS_Tutorials/lesson3.html
https://libguides.library.kent.edu/SPSS/FrequenciesCategorical
https://libguides.library.kent.edu/SPSS/FrequenciesContinuous
https://libguides.library.kent.edu/SPSS/FrequenciesContinuous
https://stats.idre.ucla.edu/spss/output/descriptive-statistics/
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This command will open a dialog box that allows you to choose one or more variables, in order to 
display their frequencies. Select the variable(s) you want to examine on the left side of this box, push the 
arrow button in the middle of the screen, and the variable(s) will appear in the list on the right side:  

After the relevant variables are selected, click the "Charts" button on the right side of the box, which 
will allow you to select the type of chart/graph to be produced:

Select whether you want to produce a bar chart,  pie chart,  or histogram, and then select any of the 
available options.  Once everything is ready, click OK, and the graph will be generated.

Syntax
• Instructions for doing this in a syntax file will be provided later.

Using PSPP
•  The same basic menu command (Analyze > Descriptive Statistics > Frequencies) also works in 
PSPP. 

Other Resources
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• Official SPSS Syntax Documentation: FREQUENCIES
• Official PSPP Documentation: FREQUENCIES
• Furman University SPSS Tutorials: Descriptive Statistics and Graphs
•  Kent  State  Statistical  Consulting:  Frequency Tables,  Descriptive Stats for One Numeric Variable 
(FREQUENCIES), 
• UCLA Statistical Consulting Group: Annotated Output

Central Tendency and Dispersion: "FREQUENCIES"
The easiest way to display the common measures of central tendency and dispersion for any variable in 
the data set  is  (surprisingly) also using the Frequencies  command, which you can access from the 
Analyze menu:  Analyze > Descriptive Statistics > Frequencies:

This command will open a dialog box that allows you to choose one or more variables, in order to 
display their frequencies. Select the variable(s) you want to examine on the left side of this box, push the 
arrow button in the middle of the screen, and the variable(s) will appear in the list on the right side.  

After the relevant variables are selected, click the "Charts" button on the right side of the box, which 
will allow you to select the specific statistics you want included:

https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_frequencies.htm
https://www.gnu.org/software/pspp/manual/html_node/FREQUENCIES.html#FREQUENCIES
http://eweb.furman.edu/~lpace/SPSS_Tutorials/lesson3.html
https://libguides.library.kent.edu/SPSS/FrequenciesCategorical
https://libguides.library.kent.edu/SPSS/FrequenciesContinuous
https://libguides.library.kent.edu/SPSS/FrequenciesContinuous
https://stats.idre.ucla.edu/spss/output/descriptive-statistics/
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Select whether you want to produce a bar chart,  pie chart,  or histogram, and then select any of the 
available options.  Once everything is ready, click OK, and the graph will be generated.

Syntax
• Instructions for doing this in a syntax file will be provided later.

Using PSPP
•  The same basic menu command (Analyze > Descriptive Statistics > Frequencies) also works in 
PSPP. 

Other Resources
• Official SPSS Syntax Documentation: FREQUENCIES
• Official PSPP Documentation: FREQUENCIES
• Furman University SPSS Tutorials: Descriptive Statistics and Graphs
•  Kent  State  Statistical  Consulting:  Frequency Tables,  Descriptive Stats for One Numeric Variable 
(FREQUENCIES), 

Alternative Option: "DESCRIPTIVES"
Beyond the Frequencies command that I use in my course, there is a more limited option for descriptive 
statistics using the Descriptives command, which you can access from the Analyze menu:  Analyze > 
Descriptive Statistics > Descriptives.   This does not allow you to see the mode or median for the 
selected variables, but some of the other commonly used measures are still available:

https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_frequencies.htm
https://www.gnu.org/software/pspp/manual/html_node/FREQUENCIES.html#FREQUENCIES
http://eweb.furman.edu/~lpace/SPSS_Tutorials/lesson3.html
https://libguides.library.kent.edu/SPSS/FrequenciesCategorical
https://libguides.library.kent.edu/SPSS/FrequenciesContinuous
https://libguides.library.kent.edu/SPSS/FrequenciesContinuous
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This is most useful for displaying a single line of statistics for a large number of variables, rather than 
displaying more information for a single variable at a time:

Syntax
• Instructions for doing this in a syntax file will be provided later.

Using PSPP
•  The same basic menu command (Analyze > Descriptive Statistics > Descriptives) also works in 
PSPP. 

Other Resources
• Official SPSS Syntax Documentation: DESCRIPTIVES
• Official PSPP Documentation: DESCRIPTIVES
• Furman University SPSS Tutorials: Descriptive Statistics and Graphs

Alternative Option: "EXAMINE"
This is another command that can be used for descriptive or exploratory data analysis.

https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_descriptives.htm
https://www.gnu.org/software/pspp/manual/html_node/DESCRIPTIVES.html#DESCRIPTIVES
http://eweb.furman.edu/~lpace/SPSS_Tutorials/lesson3.html
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Syntax
• Instructions for doing this in a syntax file will be provided later.

Using PSPP
• Instructions for doing this in PSPP will be provided later.

Other Resources
• Official SPSS Syntax Documentation: EXAMINE
• Official PSPP Documentation: EXAMINE
• UCLA Statistical Consulting Group: Annotated Output

Alternative Option: "EXPLORE"
This is another command that can be used for descriptive or exploratory data analysis.

Syntax
• Instructions for doing this in a syntax file will be provided later.

Using PSPP
• Instructions for doing this in PSPP will be provided later.

Other Resources
• Official SPSS Syntax Documentation: EXPLORE
• Kent State Statistical Consulting: Descriptive Stats for One Numeric Variable (EXPLORE)

Alternative Option: "GRAPH" or "GGRAPH"
These should produce the same basic histogram as the Frequencies command, but by giving the user 
more control.

Syntax
• Instructions for doing this in a syntax file will be provided later.

Using PSPP
• PSPP does not produce pie charts/graphs or line charts/graphs with the GRAPH command, although 
pie charts/graphs can still be produced using the FREQUENCIES command.
• PSPP does not offer the GGRAPH command.

Other Resources
•  Official  SPSS  Syntax  Documentation:  GRAPH,  GRAPH-Bar,  GRAPH-Histogram,  GRAPH-Line, 
GRAPH-Pie, GGRAPH
• Official PSPP Documentation: GRAPH, GRAPH-Bar, GRAPH-Histogram

Displaying Means: "MEANS"
This command can be used to display the mean value of the dependent variable for each category of the 
independent variable, optionally split by a third variable.

https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_examine.htm
https://www.gnu.org/software/pspp/manual/html_node/EXAMINE.html#EXAMINE
https://stats.idre.ucla.edu/spss/output/descriptive-statistics/
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.help/spss/base/idh_exam.htm
https://libguides.library.kent.edu/SPSS/Explore
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_graph.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_graph_bar.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_graph_histogram.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_graph_line.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_graph_pie.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_ggraph.htm
https://www.gnu.org/software/pspp/manual/html_node/GRAPH.html#GRAPH
https://www.gnu.org/software/pspp/manual/html_node/BAR-CHART.html#BAR-CHART
https://www.gnu.org/software/pspp/manual/html_node/HISTOGRAM.html#HISTOGRAM


18

Syntax
• Instructions for doing this in a syntax file will be provided later.

Using PSPP
• Instructions for doing this in PSPP will be provided later.

Other Resources
• Official SPSS Syntax Documentation: MEANS
• Official PSPP Documentation: MEANS
• Furman University SPSS Tutorials: Descriptive Statistics and Graphs
• Kent State Statistical Consulting: Descriptive Stats by Group (Compare Means)

https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_means.htm
https://www.gnu.org/software/pspp/manual/html_node/MEANS.html#MEANS
http://eweb.furman.edu/~lpace/SPSS_Tutorials/lesson3.html
https://libguides.library.kent.edu/SPSS/CompareMeans
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Statistical Analyses Covered in Class

Difference of Means: "T-TEST"
For a 2-sample difference of means test, SPSS uses a t-test.  This is obtained by selecting Analyze > 
Compare  Means  >  Independent  Samples  T  test  (because  it  is  assumed  that  the  samples  are 
independent -- one-sample t-tests and paired-sample t-tests are different techniques that we aren't going 
to use in this course and you probably won't see very often in Political Science research):

Once the method has been selected, you use the standard interface to select one or more Test Variables 
(the dependent variables you are trying to explain) as well as the Grouping Variable (the independent 
variable that includes the categories you are trying to compare):

Note that the Grouping Variable is shown by default with two question marks. This is because SPSS 
needs to be told which two values you want it to compare (regardless of whether the grouping variable 
only has two values or it has many values and you only want it to compare two of them).  This is done 
by clicking the Define Groups button, and then entering the values you want for Group 1 and Group 2 
(or for ordinal, interval, or ratio variables, by specifying a cut point, so that SPSS compares values 
below this point with values above this point):



20

Syntax
• Instructions for doing this in a syntax file will be provided later.

Using PSPP
• This command works the same way in PSPP, with the added benefit that the Define Groups box gives 
you the ability to select any value of the variable from a dropdown menu (which can be useful if you 
don't remember what the values are).

Other Resources
• Official SPSS Syntax Documentation: T-TEST
• Official PSPP Documentation: T-TEST, T-TEST/independent samples
• Furman University SPSS Tutorials: Independent Samples t Test
• Kent State Statistical Consulting: Independent Samples T Test, 
• UCLA Statistical Consulting Group: Annotated Output
• UNT's SPSS Short Course: t-Tests in SPSS

Analysis of Variance: "ANOVA"
To run an ANOVA, go to Analyze > Compare Means > One-Way ANOVA.  This will open a dialog 
box that allows you to choose variables for analysis:

https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_t-test.htm
https://www.gnu.org/software/pspp/manual/html_node/T_002dTEST.html#T_002dTEST
https://www.gnu.org/software/pspp/manual/html_node/Independent-Samples-Mode.html#Independent-Samples-Mode
http://eweb.furman.edu/~lpace/SPSS_Tutorials/lesson4.html
https://libguides.library.kent.edu/SPSS/IndependentTTest
https://stats.idre.ucla.edu/spss/output/t-test/
http://bayes.acs.unt.edu:8083/BayesContent/class/Jon/SPSS_SC/Module9/M9_Ttest/SPSS_M9_Ttest.htm
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Select the variable you want to examine (the dependent variable) on the left side of this box, push the 
arrow button toward the top of the screen, and the variable should then appear in the "Dependent List" 
window at the right side of the box. Do the same to select the variable that you are using to identify 
groups for comparison (the independent variable), and push the button in the middle of the screen to 
select this for the "Factor" box.

Click the "Options" box and be sure that "Descriptives" is checked, to make sure that you will get the 
means for each group; once this happens, click OK to run the analysis.
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Syntax
• Instructions for doing this in a syntax file will be provided later.

Using PSPP
• PSPP only has the ability to do oneway ANOVAs -- this is all we will be doing in this class, but more 
advanced ANOVA techniques require SPSS or other software.  For oneway ANOVAs, the same basic 
menu command (Analyze > Compare Means > One-Way ANOVA) also works in PSPP. ,; the main 
difference is that there are less options, so the option to choose Descriptive statistics is included directly 
at the bottom of the main ANOVA screen rather than in a separate Options screen.
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Other Resources
• Official SPSS Syntax Documentation: ANOVA, ONEWAY
• Official PSPP Documentation: ONEWAY
• Furman University SPSS Tutorials: One-Way ANOVA
• Kent State Statistical Consulting: One-Way ANOVA
• UNT's SPSS Short Course: Analysis of Variance (ANOVA) in SPSS

Crosstabs and Chi-Squares:  "CROSSTABS"
To set up a crosstabulation (whether just displaying a crosstab of the values of two variables or also 
calculating various test statistics), go to Analyze > Descriptive Statistics > Crosstabs.  This will open a 
dialog box that allows you to choose variables for analysis.

At this screen, select the variable you want to examine (the dependent variable) on the left side of this 
box, push the arrow button toward the top of the screen, and the variable should then appear in the 
"Row(s)" window at the right side of the box. Do the same to select the variable that you are using to 
identify groups for comparison (the independent variable), and push the button in the middle of the 
screen to select this for the "Column(s)" box.

https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_anova.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_oneway.htm
https://www.gnu.org/software/pspp/manual/html_node/ONEWAY.html#ONEWAY
http://eweb.furman.edu/~lpace/SPSS_Tutorials/lesson6.html
https://libguides.library.kent.edu/SPSS/OneWayANOVA
http://bayes.acs.unt.edu:8083/BayesContent/class/Jon/SPSS_SC/Module9/M9_ANOVA/SPSS_M9_ANOVA.htm
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You should then select the "Statistics" box and be sure that "Chi-square," "Phi and Cramer's V," and 
"Lambda" (or any other desired test statistics) are checked, to make sure that you will get the relevant 
statistics, then click Continue to return to the main variable selection screen. 
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From here click the "Cells" box and be sure that the "Observed" counts and "Column" percentages are 
selected, then click Continue to return to the main variable selection screen. Once everything is ready, 
click OK in the main screen to run the analysis.
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Syntax
• Instructions for doing this in a syntax file will be provided later.

Using PSPP
• The same basic menu command (Analyze > Descriptive Statistics > Crosstabs) also works in PSPP.  
The options are named somewhat differently, but this usually easy to figure out (e.g. "Chisq" rather than 
"Chi-square"  and  "Phi"  instead  of  "Phi  and  Cramer's  V"  for  test  statistics,  and  "Count"  instead  of 
"Observed" for cell contents).

Other Resources
• Official SPSS Syntax Documentation: CROSSTABS
• Official PSPP Documentation: CROSSTABS
• Furman University SPSS Tutorials: Chi-Square Tests
• Kent State Statistical Consulting: Crosstabs, Chi-Square Test of Independence

Scatterplots:  "GRAPH"
This command can create scatterplots, in addition to some of the types of charts/graphs described earlier.  
There are several ways to do this from the dropdown menus.  Going to Graphs > Chart Builder offers 
more features and more options, but for the purposes of my course, it  is  better to use the "legacy" 
graphing options at Graphs > Legacy Dialogs > Scatter/Dot.

https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_crosstabs.htm
https://www.gnu.org/software/pspp/manual/html_node/CROSSTABS.html#CROSSTABS
http://eweb.furman.edu/~lpace/SPSS_Tutorials/lesson13.html
https://libguides.library.kent.edu/SPSS/Crosstabs
https://libguides.library.kent.edu/SPSS/ChiSquare
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You will then have a choice among five types of graphs; for our purposes in this course, choose Simple 
Scatter, then click the Define button to choose the variables you wish to include in the plot.

Select the variable you want to examine (the dependent variable) from the list on the left side of this 
box, push the arrow button next to the Y Axis box, and the variable should then be selected as the 
dependent variable for your analysis. Do the same to select the independent variable for the X Axis box.  
(If you want to remove a variable from the list, select the variable in the right side of the box, and click 
the arrow in the middle of the screen.)  Click OK to run the analysis.
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Syntax
• Instructions for doing this in a syntax file will be provided later.

Using PSPP
• PSPP has fewer graphing options available, so setting up a scatterplot is more straightforward.  Go to 
Graphs > Scatterplot.  Select the variable you want to examine (the dependent variable) from the list 
on the left side of this box, push the arrow button next to the Y Axis box, and the variable should then be 
selected as the dependent variable for your analysis. Do the same to select the independent variable for 
the X Axis box.  (If you want to remove a variable from the list, select the variable in the right side of 
the box, and click the arrow in the middle of the screen.)  Click OK to run the analysis.

Other Resources
• Official SPSS Syntax Documentation: GRAPH, GRAPH-Scatterplot
• Official PSPP Documentation: GRAPH, GRAPH-Scatterplot
• Furman University SPSS Tutorials: Correlation and Scatterplots
• NC State SPSS Tutorials: Creating Scatter Plots

Correlation:  "CORRELATIONS"
SPSS offers a number of correlation-related analyses, but for our purposes in this course, all you need to 
run is Pearson's correlation coefficient, which is available at Analyze > Correlate > Bivariate.

One at a time (don’t worry about the order -  independent and dependent variables don’t matter for 
correlation), select each variable that you want to examine from the list on the left side of this box, and 
push the arrow button to add it to the Variables box.  (If you want to remove a variable from the list, 

https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_graph.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_graph_scatterplot.htm
https://www.gnu.org/software/pspp/manual/html_node/GRAPH.html#GRAPH
https://www.gnu.org/software/pspp/manual/html_node/SCATTERPLOT.html#SCATTERPLOT
http://eweb.furman.edu/~lpace/SPSS_Tutorials/lesson10.html
https://it.chass.ncsu.edu/tutorials/spss/section6.php
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select the variable in the right side of the box, and click the arrow in the middle of the screen.)  Make 
sure the Pearson box is checked under Correlation Coefficients, and click OK to run the analysis.

Syntax
• Instructions for doing this in a syntax file will be provided later.

Using PSPP
• PSPP  offers  fewer  options  for  correlation  analysis  than  SPSS.   Go  to  Analyze  >  Bivariate 
Correlation.  One at a time (don’t worry about the order - independent and dependent variables don’t 
matter for correlation), select each variable that you want to examine from the list on the left side of this 
box, and push the arrow button to add it to the Variables box.  (If you want to remove a variable from the 
list, select the variable in the right side of the box, and click the arrow in the middle of the screen.)  
Click OK to run the analysis (unlike SPSS, Pearson's correlation coefficient is the only technique offered 
by PSPP, so you don't need to select it).

Other Resources
• Official SPSS Syntax Documentation: CORRELATIONS
• Official PSPP Documentation: CORRELATIONS

https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_correlations.htm
https://www.gnu.org/software/pspp/manual/html_node/CORRELATIONS.html#CORRELATIONS
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• Furman University SPSS Tutorials: Correlation and Scatterplots
• Kent State Statistical Consulting: Pearson Correlation
• UCLA Statistical Consulting Group: Annotated Output

OLS Regression: "REGRESSION"
To run either a bivariate or multiple regression analysis, go to Analyze > Regression > Linear.  This 
will open a dialog box that allows you to choose variables for analysis.

Select the dependent variable on the left side of this box, push the arrow button toward the top of the 
screen, and the variable should then appear in the "Dependent" window at the right side of the box. Do 
the same to select the independent variables, and push the button in the middle of the screen to select 
this for the "Independent(s)" box.  

Using the Statistics button, make sure that Estimates, Confidence Intervals, and Model Fit are selected, 
click Continue to return to the variable selection screen, and click OK to run the analysis
.

http://eweb.furman.edu/~lpace/SPSS_Tutorials/lesson10.html
https://libguides.library.kent.edu/SPSS/PearsonCorr
https://stats.idre.ucla.edu/spss/output/correlation/
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Syntax
• Instructions for doing this in a syntax file will be provided later.

Using PSPP
• Instructions for doing this in PSPP will be provided later.

Other Resources
• Official SPSS Syntax Documentation: REGRESSION
• Official PSPP Documentation: REGRESSION, REGRESSION-Syntax
• Furman University SPSS Tutorials: Linear Regression, Multiple Correlation and Regression
• UCLA Statistical Consulting Group: Annotated Output
• UNT's SPSS Short Course: Bivariate Linear Regression in SPSS, Multiple Linear Regression in SPSS

https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_regression.htm
https://www.gnu.org/software/pspp/manual/html_node/REGRESSION.html#REGRESSION
https://www.gnu.org/software/pspp/manual/html_node/Syntax.html#Syntax
http://eweb.furman.edu/~lpace/SPSS_Tutorials/lesson11.html
http://eweb.furman.edu/~lpace/SPSS_Tutorials/lesson12.html
https://stats.idre.ucla.edu/spss/output/regression-analysis/
http://bayes.acs.unt.edu:8083/BayesContent/class/Jon/SPSS_SC/Module9/M9_Regression/SPSS_M9_Regression1.htm
http://bayes.acs.unt.edu:8083/BayesContent/class/Jon/SPSS_SC/Module9/M9_Regression/SPSS_M9_Regression2.htm
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More Advanced Analyses

Logistic Regression: "LOGISTIC REGRESSION"
More detail on these advanced techniques discussed at the end of the semester (which are not required 
for any homework assignments in this course) will be provided later. 

Using PSPP
• Instructions for doing this in PSPP will be provided later.

Other Resources
• Official SPSS Syntax Documentation: LOGISTIC REGRESSION
• Official PSPP Documentation: LOGISTIC REGRESSION
• UCLA Statistical Consulting Group: Data Analysis Example, Annotated Output
• UNT's SPSS Short Course: Logistic Regression (Binary)

Multinomial Logit: "NOMREG"
More detail on these advanced techniques discussed at the end of the semester (which are not required 
for any homework assignments in this course) will be provided later. 

Using PSPP
•  These techniques are not available in PSPP version 1.2.0.  They may be added in future versions, 
though.

Other Resources
• Official SPSS Syntax Documentation: NOMREG
• UCLA Statistical Consulting Group: Data Analysis Example, Annotated Output
• UNT's SPSS Short Course: Logistic Regression (Multinomial)

Ordered Logit/Probit: "PLUM"
More detail on these advanced techniques discussed at the end of the semester (which are not required 
for any homework assignments in this course) will be provided later. 

Using PSPP
•  These techniques are not available in PSPP version 1.2.0.  They may be added in future versions, 
though.

Other Resources
• Official SPSS Syntax Documentation: PLUM
• UCLA Statistical Consulting Group: Data Analysis Example, Annotated Output

Selection Models: [Not Currently Available]
As of SPSS version 24 and PSPP version 1.2.0, neither of these applications allows the user to conduct 
Heckman selection models.  Most academics who need these procedures use more advanced statistical 
software like STATA or R.

https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/regression/syn_logistic_regression.htm
https://www.gnu.org/software/pspp/manual/html_node/LOGISTIC-REGRESSION.html#LOGISTIC-REGRESSION
https://stats.idre.ucla.edu/spss/dae/logit-regression/
https://stats.idre.ucla.edu/spss/output/logistic-regression/
http://bayes.acs.unt.edu:8083/BayesContent/class/Jon/SPSS_SC/Module9/M9_LogReg/SPSS_M9_LogReg.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/regression/syn_nomreg.htm
https://stats.idre.ucla.edu/spss/dae/multinomial-logistic-regression/
https://stats.idre.ucla.edu/spss/output/multinomial-logistic-regression/
http://bayes.acs.unt.edu:8083/BayesContent/class/Jon/SPSS_SC/Module9/M9_MultiNomReg/SPSS_M9_MultiNomReg.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/advanced/syn_plum.htm
https://stats.idre.ucla.edu/spss/dae/ordinal-logistic-regression/
https://stats.idre.ucla.edu/spss/output/ordered-logistic-regression/
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Event Count Models: "GENLIN"
More detail on these advanced techniques discussed at the end of the semester (which are not required 
for any homework assignments in this course) will be provided later. 

Using PSPP
•  These techniques are not available in PSPP version 1.2.0.  They may be added in future versions, 
though.

Other Resources
• Official SPSS Syntax Documentation: GENLIN
•  UCLA Statistical  Consulting  Group:  Data  Analysis  Examples:  Poisson Regression  and  Negative 
Binomial Regression, Annotated Output: Poisson Regression

Survival/Duration: "SURVIVAL" (tables), "KM" (Kaplan-Meier), "COXREG" (Cox)
Note that as of version 26, SPSS doesn't allow the user to conduct parametric survival analysis (like 
Weibull models) -- only survival tables, Kaplan-Meier analyses, and Cox regressions.  Most academics 
who need to use Weibull or similar procedures use more advanced statistical software like STATA or R.

Syntax
• Instructions for doing this in a syntax file will be provided later.

Using PSPP
•  These techniques are not available in PSPP version 1.2.0.  They may be added in future versions, 
though.

Other Resources
• Official SPSS Syntax Documentation: COXREG, KM, SURVIVAL

https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/advanced/syn_genlin.htm
https://stats.idre.ucla.edu/spss/dae/poisson-regression/
https://stats.idre.ucla.edu/spss/dae/negative-binomial-regression/
https://stats.idre.ucla.edu/spss/dae/negative-binomial-regression/
https://stats.idre.ucla.edu/spss/output/poisson-regression/
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/advanced/syn_coxreg.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/advanced/syn_km.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/advanced/syn_survival.htm
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Appendix: Using Syntax Files

Syntax files are not required for any of the homework assignments in my course.  Any student who uses 
SPSS or PSPP for more advanced courses or for their own research after the class ends, though, will 
need to learn how to work directly with syntax rather than always doing everything from the dropdown 
menus at the top of the screen.

Opening a Syntax File
SPSS does not automatically create a new syntax file when it is opened, so if you want to work with a 
syntax file rather than using the graphical user interface, you will need to create or open one manually.  
To create a new syntax file, use File > New > Syntax.

If you want to use a syntax file that you have already saved, you may be able to open SPSS by double-
clicking on the syntax file (depending on how your computer is set up to handle .sps files).  If that 
doesn't work, or if you are using PSPP, you can open an existing syntax file from the SPSS/PSPP menu 
with File > Open > Syntax.

Basic Syntax Notes
•  Most examples and tutorials use upper-case to indicate commands, but this is not necessary.  The 
following should work equivalently:

CODEBOOK
    /STATISTICS COUNT PERCENT MEAN STDDEV QUARTILES.
codebook
    /statistics count percent mean stddev quartiles.
Codebook
    /Statistics Count Percent Mean Stddev Quartiles.

• Each command must start on a new line.  Commands that cover multiple lines do not need to start at 
the very beginning of the line though; it is often helpful to indent the second or later lines in a single 
command to make it easier for you to follow.
• A single command can be split into multiple lines of syntax to make it easier to follow, but this is not 
necessary.  The following should work equivalently:

CODEBOOK
    /STATISTICS COUNT PERCENT MEAN STDDEV QUARTILES.
CODEBOOK /STATISTICS COUNT PERCENT MEAN STDDEV QUARTILES.

• Each command should end with a period at the end of the final line in that command.  If a period is 
omitted, SPSS should interpret a blank line as ending the previous command, but it is always better to 
include the period just to be avoid confusion or errors later if you edit the syntax file.
• Subcommands are usually separated from the main command by slashes:
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CODEBOOK
    /STATISTICS COUNT PERCENT MEAN STDDEV QUARTILES.

• All text included within apostrophes or quotation marks (such as variable labels or value labels) must 
be contained on a single line of syntax.

Pasting Commands into Syntax Window
Even if you are using the graphical user interface to run your SPSS commands, you may still choose to 
paste the commands into the syntax window, where they can be saved or edited later.  Almost every 
dropdown menu includes a "Paste" button at the bottom of the menu; clicking this button rather than 
"OK" will paste the command syntax in the syntax window rather than running it:

You can also see how a command is structured by looking at the output from any command that you 
have run using the drop-down menus.  SPSS automatically places the syntax for each command in the 
output file before it displays the output of the command.

Running Commands from the Syntax Window
You  can  run  a  single  command  by  highlighting  the  command  using  your  mouse,  then  using  the 
dropdown menu (Run > Selected) in either SPSS or PSPP.  SPSS also includes a number of icons at the 
top of the screen, one of which looks like a "play" button (a sideways triangle); this can be used to run 
the selected command.

You can run the entire syntax file at once by using the dropdown menu (Run > All) in either SPSS or 
PSPP, by using your mouse (or Edit > Select All in SPSS) to select the entire syntax file and then 
clicking the "play" button as described above.
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Appendix: Generating, Recoding, and Labeling Variables

As users get more advanced, they will need to manipulate variables in their data sets, rather than just 
taking them in their original form.  This can be done with dropdown menus, but it is much easier with 
syntax files.

Generating and Recoding Variables:
• Official SPSS Syntax Documentation: COMPUTE, IF, RECODE, RENAME VARIABLES
• Official PSPP Documentation: COMPUTE, IF, RECODE, RENAME VARIABLES

• Kent State Statistical Consulting: Computing Variables, Recoding Variables
•  UCLA Statistical  Consulting  Group:  Creating and Recoding Variables,  Using SPSS Functions for 
Making and Recoding Variables

Formatting and Labeling Variables:
•  Official  SPSS  Syntax  Documentation:  APPLY DICTIONARY,  FORMATS,  MISSING VALUES, 
STRING, VALUE LABELS, VARIABLE LABELS
•  Official  PSPP Documentation: APPLY DICTIONARY,  FORMATS,  MISSING VALUES,  STRING, 
VALUE LABELS, VARIABLE LABELS

• Kent State Statistical Consulting: Defining Variables, Variable Types, Date-Time Variables
• UCLA Statistical Consulting Group: Labeling and Documenting Data, Using Dates in SPSS

https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_compute.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_if.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_recode.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_rename_variables.htm
https://www.gnu.org/software/pspp/manual/html_node/COMPUTE.html#COMPUTE
https://www.gnu.org/software/pspp/manual/html_node/IF.html#IF
https://www.gnu.org/software/pspp/manual/html_node/RECODE.html#RECODE
https://www.gnu.org/software/pspp/manual/html_node/RENAME-VARIABLES.html#RENAME-VARIABLES
https://libguides.library.kent.edu/SPSS/ComputeVariables
https://libguides.library.kent.edu/SPSS/RecodeVariables
https://stats.idre.ucla.edu/spss/modules/creating-and-recoding-variables/
https://stats.idre.ucla.edu/spss/modules/using-spss-functions-for-making-and-recoding-variables/
https://stats.idre.ucla.edu/spss/modules/using-spss-functions-for-making-and-recoding-variables/
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_apply_dictionary.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_formats.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_missing_values.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_string.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_value_labels.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_variable_labels.htm
https://www.gnu.org/software/pspp/manual/html_node/APPLY-DICTIONARY.html#APPLY-DICTIONARY
https://www.gnu.org/software/pspp/manual/html_node/FORMATS.html#FORMATS
https://www.gnu.org/software/pspp/manual/html_node/MISSING-VALUES.html#MISSING-VALUES
https://www.gnu.org/software/pspp/manual/html_node/STRING.html#STRING
https://www.gnu.org/software/pspp/manual/html_node/VALUE-LABELS.html#VALUE-LABELS
https://www.gnu.org/software/pspp/manual/html_node/VARIABLE-LABELS.html#VARIABLE-LABELS
https://libguides.library.kent.edu/SPSS/DefineVariables
https://libguides.library.kent.edu/SPSS/VariableTypes
https://libguides.library.kent.edu/SPSS/DatesTime
https://stats.idre.ucla.edu/spss/modules/labeling-and-documenting-data/
https://stats.idre.ucla.edu/spss/modules/using-dates-in-spss/
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Appendix: Sorting and Selecting Data for Analysis

Many statistical analyses will require users to analyze only a subset of the data set being used, perhaps 
to focus only on one election, one Congressional session, or one type of country -- or to run separate 
analyses for different elections, sessions, or types of countries.

•  Official  SPSS  Syntax  Documentation:  DO IF,  DROP/KEEP subcommands in SAVE,  FILTER,  IF, 
SELECT IF, SORT CASES, SPLIT FILE, TEMPORARY
• Official PSPP Documentation: DO IF, DROP/KEEP subcommands in SAVE, FILTER, IF, SELECT IF, 
SORT CASES, SPLIT FILE, TEMPORARY

• Kent State Statistical Consulting explanation: Sorting Data, Splitting/Grouping Data
• UCLA Statistical Consulting Group explanation: Using the Sort Cases and Split File Commands, How 
Can I Analyze a Subset of My Data?, Subsetting Data
• UNT's SPSS Short Course: Select Cases / Create a Filter Variable
• UT SPSS Tutorials: SPSS: Data Manipulation and Advanced Topics

Appendix: Merging Two Data Sets

More advanced users may need to combine multiple data sets for analysis, because no single data set is 
able  to  meet  all  of  their  needs.   For  example,  an international  conflict  scholar  may need to  merge 
together data sets cover the conflict behavior, democracy levels, military power, and other attributes of 
the countries being studied.  There may also be a need to aggregate (or concatenate) several different 
data sets  that  contain the same variables for  different  cases (perhaps different  elections or different 
polls).

• Official SPSS Syntax Documentation: ADD FILES, MATCH FILES
• Official PSPP Documentation: ADD FILES, MATCH FILES

• UCLA Statistical Consulting Group: Concatenating Data Files, Match Merging Data Files
•  UNT's  SPSS Short  Course:  Use the Merge Function to Add Cases,  Use the Merge Function to Add 
Variables
• UT SPSS Tutorials: SPSS: Data Manipulation and Advanced Topics

https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_do_if.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_save_drop_keep.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_filter.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_if.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_select_if.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_sort_cases.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_split_file.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_temporary.htm
https://www.gnu.org/software/pspp/manual/html_node/DO-IF.html#DO-IF
https://www.gnu.org/software/pspp/manual/html_node/SAVE.html#SAVE
https://www.gnu.org/software/pspp/manual/html_node/FILTER.html#FILTER
https://www.gnu.org/software/pspp/manual/html_node/IF.html#IF
https://www.gnu.org/software/pspp/manual/html_node/SELECT-IF.html#SELECT-IF
https://www.gnu.org/software/pspp/manual/html_node/SORT-CASES.html#SORT-CASES
https://www.gnu.org/software/pspp/manual/html_node/SPLIT-FILE.html#SPLIT-FILE
https://www.gnu.org/software/pspp/manual/html_node/TEMPORARY.html#TEMPORARY
https://libguides.library.kent.edu/SPSS/SortData
https://libguides.library.kent.edu/SPSS/SplitData
https://stats.idre.ucla.edu/spss/modules/using-the-sort-cases-and-split-file-commands/
https://stats.idre.ucla.edu/spss/modules/how-can-i-analyze-a-subset-of-my-data/
https://stats.idre.ucla.edu/spss/modules/how-can-i-analyze-a-subset-of-my-data/
https://stats.idre.ucla.edu/spss/modules/ubsetting-data/
http://bayes.acs.unt.edu:8083/BayesContent/class/Jon/SPSS_SC/Module7/SPSS_M7_1.htm
https://stat.utexas.edu/images/SSC/documents/SoftwareTutorials/SPSS_Advanced.pdf
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_add_files.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_match_files.htm
https://www.gnu.org/software/pspp/manual/html_node/ADD-FILES.html#ADD-FILES
https://www.gnu.org/software/pspp/manual/html_node/MATCH-FILES.html#MATCH-FILES
https://stats.idre.ucla.edu/spss/modules/concatenating-data-files/
https://stats.idre.ucla.edu/spss/modules/match-merging-data-files/
http://bayes.acs.unt.edu:8083/BayesContent/class/Jon/SPSS_SC/Module8/SPSS_M8_1.htm
http://bayes.acs.unt.edu:8083/BayesContent/class/Jon/SPSS_SC/Module8/SPSS_M8_2.htm
http://bayes.acs.unt.edu:8083/BayesContent/class/Jon/SPSS_SC/Module8/SPSS_M8_2.htm
https://stat.utexas.edu/images/SSC/documents/SoftwareTutorials/SPSS_Advanced.pdf
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Other Useful Resources

My web site for this courses includes an Additional Online Resources page, which lists a number of 
statistical reference books and textbooks if you want to go further in using statistical methods than we 
did in this course.  That page also includes links to a variety of political polls, survey data sets, and other 
data sets that are widely used by political scientists, which you might find useful in future research 
projects:

<  https://www.paulhensel.org/Teaching/psci2300r.html >

SPSS-Specific Resources
• Official SPSS Guide to Command Syntax:

< h t t p s : / / w w w . i b m . c o m / s u p p o r t / k n o w l e d g e c e n t e r / S S LV M B _ 2 2 . 0 . 0 /
com.ibm.spss.statistics.reference/spss/base/syn_refintro_overview.htm>

• Official SPSS Tutorials (step by step guides for common tasks and commands):
<https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.tut/
spss/tutorials/introtut2.htm>
<https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.cs/
spss/tutorials/casestudies_intro.htm>

• SPSS Tutorials from Kent State University Libraries:  <https://libguides.library.kent.edu/SPSS>
• SPSS Tutorials from UCLA:  <https://stats.idre.ucla.edu/spss/>

Learning Modules: <https://stats.idre.ucla.edu/spss/modules/>
Frequently Asked Questions: <https://stats.idre.ucla.edu/spss/faq/>

• SPSS Tutorials from UNT:  <http://bayes.acs.unt.edu:8083/BayesContent/class/Jon/SPSS_SC/>
• SPSS Tutorials from UT:   <https://stat.utexas.edu/training/software-tutorials#spss>
• SPSS Tutorials from the University of Wisconsin:

The Basics:  <https://ssc.wisc.edu/sscc/pubs/spss/classintro/spss_students1.html>
Statistics & Graphs:  <https://ssc.wisc.edu/sscc/pubs/spss/classintro/spss_students2.html>

PSPP-Specific Resources
• Official PSPP Manual (more detail on what each command does and what options are available):  

<https://www.gnu.org/software/pspp/manual/>

• Basic Stats in PSPP (from Norm Lewis at the University of Florida):
<http://www.bikeprof.com/uploads/9/0/6/5/9065192/stats_intro_in_pspp_handout_npl.pdf>

• PSPP Tutorial from NC State University:
<https://it.chass.ncsu.edu/tutorials/pspp/index.php>

Advice on Choosing Statistical Techniques
• Choosing the Correct Statistical Test (from UCLA):

<https://stats.idre.ucla.edu/other/mult-pkg/whatstat/>
• SPSS Statistics Coach (from IBM, the makers of SPSS):

< h t t p s : / / w w w. i b m . c o m / s u p p o r t / k n o w l e d g e c e n t e r / e n / S S LV M B _ 2 2 . 0 . 0 /
com.ibm.spss.statistics.coach/spss/statcoach/statcoach_main.htm>

http://www.paulhensel.org/Teaching/psci2300r.html
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_refintro_overview.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.reference/spss/base/syn_refintro_overview.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.tut/spss/tutorials/introtut2.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.tut/spss/tutorials/introtut2.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.cs/spss/tutorials/casestudies_intro.htm
https://www.ibm.com/support/knowledgecenter/SSLVMB_22.0.0/com.ibm.spss.statistics.cs/spss/tutorials/casestudies_intro.htm
https://libguides.library.kent.edu/SPSS
https://stats.idre.ucla.edu/spss/
https://stats.idre.ucla.edu/spss/modules/
https://stats.idre.ucla.edu/spss/faq/
http://bayes.acs.unt.edu:8083/BayesContent/class/Jon/SPSS_SC/
https://stat.utexas.edu/training/software-tutorials#spss
https://ssc.wisc.edu/sscc/pubs/spss/classintro/spss_students1.html
https://ssc.wisc.edu/sscc/pubs/spss/classintro/spss_students2.html
https://www.gnu.org/software/pspp/manual/
http://www.bikeprof.com/uploads/9/0/6/5/9065192/stats_intro_in_pspp_handout_npl.pdf
https://it.chass.ncsu.edu/tutorials/pspp/index.php
https://stats.idre.ucla.edu/other/mult-pkg/whatstat/
https://www.ibm.com/support/knowledgecenter/en/SSLVMB_22.0.0/com.ibm.spss.statistics.coach/spss/statcoach/statcoach_main.htm
https://www.ibm.com/support/knowledgecenter/en/SSLVMB_22.0.0/com.ibm.spss.statistics.coach/spss/statcoach/statcoach_main.htm

	Introduction
	Accessing SPSS or PSPP
	Using SPSS or PSPP
	Switching Between Windows
	The "Data Editor" Window
	The "Output Viewer" Window (and copying output for your homework assignments)
	The "Syntax Editor" Window
	Opening SPSS (.sav) Data Sets
	Opening or Importing Other Types of Data

	Summarizing the Data Set
	Variable Codebook: "DISPLAY"
	Alternative Option: "CODEBOOK"

	Descriptive Statistics
	Frequency Distributions: "FREQUENCIES"
	Bar Graphs, Pie Charts, and Histograms: "FREQUENCIES"
	Central Tendency and Dispersion: "FREQUENCIES"
	Alternative Option: "DESCRIPTIVES"
	Alternative Option: "EXAMINE"
	Alternative Option: "EXPLORE"
	Alternative Option: "GRAPH" or "GGRAPH"
	Displaying Means: "MEANS"

	Statistical Analyses Covered in Class
	Difference of Means: "T-TEST"
	Analysis of Variance: "ANOVA"
	Crosstabs and Chi-Squares:  "CROSSTABS"
	Scatterplots:  "GRAPH"
	Correlation:  "CORRELATIONS"
	OLS Regression: "REGRESSION"

	More Advanced Analyses
	Logistic Regression: "LOGISTIC REGRESSION"
	Multinomial Logit: "NOMREG"
	Ordered Logit/Probit: "PLUM"
	Selection Models: [Not Currently Available]
	Event Count Models: "GENLIN"
	Survival/Duration: "SURVIVAL" (tables), "KM" (Kaplan-Meier), "COXREG" (Cox)

	Appendix: Using Syntax Files
	Appendix: Generating, Recoding, and Labeling Variables
	Appendix: Sorting and Selecting Data for Analysis
	Appendix: Merging Two Data Sets
	Other Useful Resources
	Advice on Choosing Statistical Techniques


